Gallery of Lights

The Site => Ideas or Reports about the Site => Bug Reports => Topic started by: rjluna2 on May 08, 2018, 06:51:43 pm

Title: Errors when posting in forum
Post by: rjluna2 on May 08, 2018, 06:51:43 pm
Today, when I tried to log in and/or log out, I get error message:

When I logged in:

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/disaster/public_html/sanriovillage.com/galleryoflights/mb/Sources/Load.php(225) : runtime-created function on line 3

When I logged out:

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/disaster/public_html/sanriovillage.com/galleryoflights/mb/Sources/Load.php(225) : runtime-created function on line 3

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/disaster/public_html/sanriovillage.com/galleryoflights/mb/Sources/Load.php(225) : runtime-created function on line 3

When I tried to reload from the favorite page, it works without further problem.
Title: Errors when posting in forum
Post by: xmaslightguy on May 09, 2018, 11:56:52 pm
When posting in the forum tonight I would get a blank page with this on it:

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/disaster/public_html/sanriovillage.com/galleryoflights/mb/Sources/Load.php(225) : runtime-created function on line 3

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/disaster/public_html/sanriovillage.com/galleryoflights/mb/Sources/Load.php(225) : runtime-created function on line 3

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/disaster/public_html/sanriovillage.com/galleryoflights/mb/Sources/Load.php(225) : runtime-created function on line 3

But the comment would actually still post.
Also at the top of all pages in the forum, there is stuff like:


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/disaster/public_html/sanriovillage.com/galleryoflights/mb/Sources/Load.php(225) : runtime-created function on line 3

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/disaster/public_html/sanriovillage.com/galleryoflights/mb/Sources/Load.php(225) : runtime-created function on line 3 
Title: Re: Errors when posting in forum
Post by: joe_347V on May 10, 2018, 02:04:02 am
Yeah I've noticed problems with the forum too, like xmaslightguy and rjluna said, the action would still get performed but the site gives a error page instead of a confirmation page. As both of your threads are about the same problem, I've combined them into one thread. I've also notified the site owner, Ian about the problem

-Joe
Title: Re: Errors when posting in forum
Post by: Model25FanForever on May 10, 2018, 07:33:21 am
I had this problem too the other day. It hasn't gone away but its preventing actions like posting, messages, and logins.  

I managed to log in by logging in on one page, error would come up, then open up a new tab with GOL and then the site seems to be working fine for the most part. The error still pops up in the top of the pages too.
Title: Re: Errors when posting in forum
Post by: rjluna2 on May 10, 2018, 07:19:55 pm
I also noticed that our avatar picture seems to be missing ???
Title: Re: Errors when posting in forum
Post by: lightingfan8902 on May 10, 2018, 10:08:42 pm
Yeah, me too! I'm getting that error message too.
Title: Re: Errors when posting in forum
Post by: xmaslightguy on May 10, 2018, 11:42:17 pm
Quote from: rjluna2
I also noticed that our avatar picture seems to be missing ???
Interesting...
And if you attempt to look at one of the avatars by its link, you get that same list of 3 errors...followed by a bunch of gibberish (which is probably the actual image data)

Oh and....
if you attempt to view:
disasterous.org/home/disaster/public_html/sanriovillage.com/galleryoflights/mb/Sources/Load.php
you get a: 404 Not Found

if you attempt to view (which I believe is the actual address):
disasterous.org/sanriovillage.com/galleryoflights/mb/Sources/Load.php
you get 2 words: "Hacking attempt..."

---------
So what's
disasterous.org & sanriovillage.com ?? gonna have to go check those out :lol:
Title: Re: Errors when posting in forum
Post by: Model25FanForever on May 11, 2018, 06:18:33 am
Yeah LilCinnamon is looking into it now
Title: Re: Errors when posting in forum
Post by: joe_347V on May 11, 2018, 11:54:55 pm
Yeah issue appears to be an issue with the forum software being too old

See here (http://www.galleryoflights.org/mb/index.php?topic=1418)

(Quote)
---------
So what's
disasterous.org & sanriovillage.com ?? gonna have to go check those out :lol:
---------
IIRC both domains are also owned by Ian and before GoL was moved to the GalleryofLights.org domain, it used to be a subpage of one of those sites. I guess some of the code in the back end still references the old domains.
Title: Re: Errors when posting in forum
Post by: xmaslightguy on May 12, 2018, 09:38:45 am
@joe_347V:
Interesting bit of history there.
Out of curiosity I did try viewing both... one said it was closed, the other said coming soon .lol.
Title: Re: Errors when posting in forum
Post by: rjluna2 on May 12, 2018, 03:11:12 pm
Yeah issue appears to be an issue with the forum software being too old

See here (http://www.galleryoflights.org/mb/index.php?topic=1418)

Thanks for the heads up :)