Home     Back to forums     Login
Album list     Last uploads     Last comments     Most viewed     Top rated     My Favorites     Search
Home > User galleries > basilicon89 > My Traffic Signal Equipment
Click to view full size image

Bad segment

This caught me totally by surprise. My countdown crosswalk signal recently had a segment go bad in the right most number display, middle segment.

As you can see it should be displaying 14 but is missing the center to connect the "4" together.

I took it apart to do some mod work but the unit is 99% sealed up and not designed to be taken apart.. That segment does not light when I switch on the test mode on the back of the module. The display shows "80" when it should show "88"

Despite this, the signal operates normally. I am thinking there was a cold solder joint inside the signal. But that would be a guess.

This is a fix I didn't want to put money into at the moment. For now its gotta go on the backburner until I can find a similar fixture to replace it

IMG_2368.JPG 0822131158.jpg broken_countdown_segment.jpg inside_integrated_head.jpg CIMG9816.JPG
File information
Filename:broken_countdown_segment.jpg
Album name:basilicon89 / My Traffic Signal Equipment
Keywords:Traffic_Lights
Filesize:90 KiB
Date added:Aug 05, 2013
Dimensions:1143 x 857 pixels
Displayed:436 times
URL:http://www.galleryoflights.org/mb/gallery/displayimage.php?pid=16022
Favorites:Add to Favorites

Comment 1 to 3 of 3
Page: 1

joe_347V   [Aug 05, 2013 at 01:23 AM]
joe_347V
Yeah, my GE countdown module is all sealed up too. Mine dosen't have the DIP switches on the back for the test mode.

rlshieldjr   [Aug 05, 2013 at 05:12 AM]
rlshieldjr
Who makes it? Maybe once you open it, you could just replace 1or2 LEDs that blew, as they are probably series-parallel.

basilicon89   [Aug 14, 2013 at 02:28 AM]
basilicon89
Bought its replacement today, awaiting shipment. The new one is made by Excellence Optoelectronics (EOI)


Comment 1 to 3 of 3
Page: 1